Arm Mbed OS support forum

Firmware on frdm kl25z

Hello everyone

I’m getting an error saying I have an old firmware on my frdm kl25z board an that I should update the DAPLink

Tried to follow the instructions on Firmware FRDM KL25Z - Handbook | Mbed
It is stated there that the latest version is 0243.
But the file provided updates to v.0203

Tried to downgrade and succeeded to downgrade to 0201 and back to 0203

What should I do?

Thanks

Hi,

You can goto the DAPLink firmware page here:
https://armmbed.github.io/DAPLink/

and type KL25Z in the text box.

Thanks,
Toyo