Arm Mbed OS support forum

Mbed studio 1.2

Hi ,
I am new to this forum but I would like to ask simple question.
I am running Windows version
I got example mbed_os_example_blinky-5.
I was able to build it but how I can step in program with debugger ?
When I hit button connect to run nothing is happening.

I selected Multitech XDOT as taget as suggested by multitech .

What I am doing wrong ?
Can I get advice how to use Mbed studio to debug on my target.
Thanks

Do you have the green network icon showing, as illustrated here

Screenshot at 2020-08-26 11-08-17

No , I do not see one.
In device manager I see
mbed serial port com6
and
xr21v1410 USB UART ( com4)
What I have missing ?

That means it has not detected OpenSDA (CMSIS-DAP).

According to this link, you need to install OpenOCD.
https://os.mbed.com/teams/MultiTech/wiki/Using-Eclipse-and-mbed-5-for-MTS-Devices

Hi ,
Thanks for a reply , just installed OpenOCD for the windows but still no green on target.
What else is missing.
I am using mbed studio not eclipe

These articles may help:

https://os.mbed.com/docs/mbed-os/v6.2/debug-test/setting-up-a-local-debug-toolchain.html

https://os.mbed.com/docs/mbed-studio/current/targets/custom-targets.html

Clicking on that custom blue chip icon might be the best bet

Screenshot at 2020-08-26 14-44-00

Hopefully your USB device shows something like this…

Screenshot at 2020-08-26 15-02-31

Hi ,
First of all I do not have eclipse installalled

only mbed studio
and when I did click on select target dialog I cannot select usb device .
My device manager

Looking at your attached screenshot, what is listed in that drop down box “USB device”…

Sorry I may have misdirected you, even though I realise that you only have Mbed Studio.

Did you you read that page: https://os.mbed.com/docs/mbed-os/v6.2/debug-test/setting-up-a-local-debug-toolchain.html

There it explains, under the title “Running a debug server” to use pyOCD (which has known limitations and could well be the reason you cannot see the USB device) or OpenOCD.

To connect to the debug interface, OpenOCD support most boards. If the debug interface on your board is classified as ‘CMSIS-DAP’ or ‘DAPLink’ (most boards), you can use pyOCD. If not, use OpenOCD."

If it is still not working then maybe worth trying this option:

https://armmbed.github.io/DAPLink/

Enter your board name in the search box and it will return some instructions and a link some firmware

Hi ,
When I press on manage custom target USB device , I do not see anything in a list.

In case of you link I put Xdot in search box , but I have multiple choice and do not know which is mine.
Mine is MultiCennect XDot, which is look like suppoted by mbed.
Can you tell me what I need to do so Mbed IDE will find this device?
I am using Mbed ide not Eclipce.
OpenOSD is already installed.
Why is is so diffical to take something from the box which is suuport and connect to it. It is your tools and according to your web site Mbed should support my controleler. What is the problem ?
Thanks

STM32L151CCU6 Processor

High performance ARM® Cortex™-M3 Core
32MHz, 32kB RAM, 256kB Flash

Hi ,
I can put DALnk firmware on device , but since I do not have any control what if something go wrong , how I can recover from it.

That looks correct.

The instructions on the page seem quite straightforward:

  1. Download the firmware file.
  2. While holding down the boards reset button, connect the boards USB debug port to the computer. It should enumerate and mount as BOOTLOADER or MAINTENANCE . For boards that enumerate as BOOTLOADER see our blog to determine if an update for the DAPLink bootloader is available.
  3. Drag-and-drop the firmware file onto the mounted drive.
  4. Wait for the file copy operation to complete.
  5. Power cycle the board. It will now enumerate and mount as DAPLINK or the name of the board.

There is nothing that should go wrong (famous last words). :stuck_out_tongue_closed_eyes:

You should then hopefully be able to then see your board as a DAP-LINK USB device in MBED Studio, as per your earlier screenshot.


I do not want to be your pain in you know where but in device manager screen shot which is debug port ?

I switched from Windows to Linux so I can’t comment on the Device Manager. My suggestion is stick to what you see in Mbed Studio.

Here is a blog that was written about DAPlink… https://os.mbed.com/blog/entry/DAPLink-bootloader-update/

Just to add, I have another board which required a DAPlink for it to work. I uploaded the wrong bin file and nothing happened. I was still able to upload the correct one.

STEP 1… is to get your board into “MAINTENANCE” mode. If that does not work, then who knows.

So, unplug USB cable from board so that it is powered down, hold the reset button and then reinsert the USB cable.

That should switch it to maintenance mode.

Maybe then have a look at Device Manager to see what it does, if that’s going to satisfy your curiosity.

Hi ,
I installed DapLink firmware but my board still nor enumerated as daplink.

In device manager I see now unknown device WebUSB: CMSIS-DAP.
What is going on , why it did not enumerated as daplink.

Hi dear:
I am just looking for solution not for the sorry.

what was the name of the .bin file?

Hi , thanks for reply.
File name was 0253_k20dx_xdot_l151_0x8000.bin
https://armmbed.github.io/DAPLink//firmware/0253_k20dx_xdot_l151_0x8000.bin

Did you read that blog about updating as it mentions that for windows 8/10 you need to stop “services.msc”.

Also in that blog is an older version 0244_k20dx…

No harm trying that too to see if there is any difference.

Hi ,
I did restart my device it was enumerated as maintenance,
I went on services and stopped storage service.
Dragged on this drive. It was rebooted and still situation is the same ,
There is no DAPLINK device.
What is going on ?