Arm Mbed OS support forum

Mbed Studio 1.4.2 While loop problem

I some time worked with some SD card, SPI communication and I2C LCD project Today I just added button digital IN for program control and faced up with strange problem:
For now While loop can be used with expression (1) only. In this case I see only one warning “[Warning] @0,0: L3912W: Option ‘legacyalign’ is deprecated.” and program compile and work fine. If I adding something else in While expression like (!button) - program does not compile anymore and I’m receiving fault: “[Error] @0,0: L6218E: Undefined symbol rtos::ThisThread::sleep_for(std::__2::chrono::duration<unsigned int, std::__2::ratio<1ll, 1000ll> >) (referred from BUILD/NUCLEO_F429ZI/ARMC6/main.o).” and new warning “[ERROR] Warning: L3912W: Option ‘legacyalign’ is deprecated.”
Board as you can see is UCLEO_F429ZI, Mbed Studio 1.4.2, libraries - newest

What can be wrong there ? Everything worked fine some days ago, before software upgrade.

Hello,

If you think it is related to the MbedStudio update then look here.

BR, Jan

Hello,
Thank you, reverting to Studio 1.4.1 helped, my code work again :slight_smile: