Mutex parameter error

have been working on a program for about a year now and have made great progress until something changed over the weekend. i shut down may computer and left for the weekend. when i started up again on the monday I started getting a mutex parameter error every time I ran the program that worked fine on friday. (no edits made as I have a practice of fresh build before editing to confirm good code). I have no idea what the parameter is to chanage/fix it. how do i find out? this error has plagued me for 3 weeks. I am using mbed studio and even tried the keil cloud. same errors.
Here is the error:
++ MbedOS Error Info ++
Error Status: 0x80010133 Code: 307 Module: 1
Error Message: Mutex: 0x0, Parameter error
Location: 0x59E1
Error Value: 0x0
Current Thread: main Id: 0x200019FC Entry: 0x37ED StackSize: 0x1000 StackMem: 0x200004B0 SP: 0x20027F44
For more info, visit: mbedos-error
– MbedOS Error Info –

I am using the MAX32625MBED board. have 2 boards thinking maybe there was a problem with one but both doing the same.
PLEASE HELP, right now because of this my project is on a hold.
Rob Berry


  • tools probably do not have impact on this and there were no update for MbedStudio in last few weeks
  • an error in your code is very likely, but you said you changed nothing
  • an error in MbedOS is also very likely, but you said you changed nothing

With this description it is really hard to say what can be the reason. You can try to debug your code, if is that feature available for your target or debug via the printf to dedicate where exactly the program crash.
If you not do not use a repository for your project and its Commits until now, maybe you have good reason for that now.

Did you try to create a new empty program and copy only the content of your code?
And also version of Mbed OS that you use could be good information.

There were strange issue with Mutex and a MAXim target last year (not verified) - Using std::printf causes a mutex error? - Mbed OS / Hello world! - Arm Mbed OS support forum

BR, Jan

I did create a new blinky project and it causes the same error. this is one reason i wondered did something change in the mbed world to break it. the error I posted was caused by an unedited blinky code.
its real tough to design with mbed when this stuff happens and there is NO tech support except the community. I’d happily pay a reasonable fee to get help fixing this my project is an update to an existing product and we need to finish it. I am even considering abandoning mbed…
Also I did see the post you referenced. Thats why i tried blinky with no printf statements.

Yeah, that is a risk when you are using open source projects.

Ok, I found this issue reported on github and it seems to be related to your Issue, but disagrees with that “I haven’t changed anything”. The issue seems to be solved and closed 7 hours ago.
You can try to downgrate MbedOS to version 6.9 until it comes live version.

BR, Jan

Downgrading to 6.9.0 allowed it to run!!!
I really appreciate it. neer thought of checking the github for solutions.
Best Regards,

i was facing same issue…

same issue…..