Should I use latest OS in keil studio?

I started the program in keil studio for the first time in 3 months.
I tried to run the rotary encoder using a timer interrupt function and got an error. It worked fine before.
The OS version used is 5.17 with baremetal.


please be so kind and fill what error you are facing and try to better describe what meaning with It worked fine before (before what?).

I remember your older post How to use Rotary-Encoder using MBED OS6.16 in Keil Studio - Mbed OS - Arm Mbed OS support forum

BR, Jan

thank u Jan .
It means that I was able to move it during the my older post .

If you need the code, I can provide it.

++ MbedOS Error Info ++
Error Status: 0x80010133 Code: 307 Module: 1
Error Message: Mutex: 0x200016C8, Not allowed in ISR context
Location: 0x80083E5
Error Value: 0x200016C8
Current Thread: main Id: 0x20001AE4 Entry: 0x8005AFD StackSize: 0x1000 StackMem: 0x200004E0 SP: 0x20017F1C
For more info, visit: mbedos-error
– MbedOS Error Info –

Are you sure you have the baremetal set up? The error is exactly same like before.

BR, Jan

You are correct.
My mistake, baremetal was not set up.
Thanks for the response.