Arm Mbed OS support forum

SoftSerial problem L432KC

Hi all,
If anybody can help with my problem, i will appreciate.
I try to use Softserial on Nucleo32 L432KC.
On 4800baud, it’s ok, but on 9600baud or up, it’s not working ???
Is it a problem of frequency ?
thanks,

What Du you mean with SoftSerial, I use Serial and RawSerial on the L432 all the time and it works. What are the serial port Pins?
Sample code?

Hi,

Frederic probably mean this old SoftSerial library.

@headedspy had same/similar Issue (NUCLEO Software Serial problem). Maybe he solved that.

BR, Jan

Hi,
Thank to you to try to help me.
I need 2 more serial on L432.
I need debug on USB, one more serial for Xbee and one more for GPS.
But there is only 2 hardware serial, so i decide to use a software serial.
Then ho suprprise, it does not work at 9600 or 19200. So i try at 4800, then it’s working in dual sens. ???
Prehaps, the timer use to these soft serial library (and bufferSerailsoft) use 32768kHz for rtc too !!!
While, others seems to use it without problem, i dont understood while it’s do not work for me.

I understand, a software serial is very timing sensitive, I cannot help here. You can take another L4 MCU which has 3 serials.
Regards Helmut

If it is a clock issue, you could try to use the HSE external oscillator instead of the internal one. It’s far more accurate.

Thanks Kentaro,
It’s right that this nucleo board use a 32.768 kHz crystal on board.
I will try to use the internal clock, or the 8MHz from the ST-link.
But, i dont want to solder or unsolder, because students do not have to do that.
Yes, i’m teacher.
Thanks to all,

Hi Giamarchi,
I checked the SoftSerial library on L432KC board and confirmed it does not work.
Inside of timer interrupt especially 1st calling sequence was not come to expected time period.
I could not reach problem itself (maybe inside OS TimerEvent) but make a countermeasure to avoid it.
Please try following linked program.
https://os.mbed.com/users/kenjiArai/code/Test_SoftSerial_for_L432KC/