Arm Mbed and Pelion Device Management support forum

BBC Microbit.h latest library supporting v1.5 ubits with LSM303AGR accellerometer

Is there an updated version of the mbed Microbit library that ideally supports both the original 1.3 boards and the newer 1.5 boards that are fitted with the LSM303AGR accellerometer chip?

I have the accellerometer code working on an old 1.3 Microbit but it does not detect any motion on the 1.5 board.

If need be I’m happy for now to build with two different include files but would prefer it to select between them.

Thanks

Peter

Hi Peter,

1.3 and 1.5 have different chips and most probably requires different files unless they have similar I2C commands. I would recommended you to search from Github or microbit forum proper libraries.


Regards,
Pekka