Arm Mbed OS support forum

Ble security manager passkey

Hello everyone!
I am a newbee in the BLE stack. Now I’m trying to implement security manager functionality based on mbed’s /mbed-os-example-ble/BLE_BatteryLevel. To do this I’m using functions “_ble.securityManager().init(true, false, SecurityManager::IO_CAPS_DISPLAY_ONLY);”, “_ble.securityManager().setSecurityManagerEventHandler(this);” in ble “on_init_complete” handler. I’m also inheriting my class as “public SecurityManager::EventHandler”. To show generated password, I use “passkeyDisplay” callback. It worked, but while trying to connect to a device, the procedure fails with code 132 - wrong passkey. I’m sure that I passed correct passkey to the controller.
My board is nRF52832-based E73-2G4M04S. I tried to use platformio based mbed framework with mbed version 5.14.1 as well as mbed online compiler. I tried also some different experiments, but it didn’t work.
Maybe I missed something important? Maybe I supposed to handle passkey by myself? Please help me