Cannot receive messages with mbed-os-example-lorawan


I’m trying the [mbed-os-example-lorawan] example with a NUCLEO L476RG device. The port itself worked and I am able to send uplink messages, which I can see on application server.

However, if I send downlink data, I can see according packets in my Gateway, but the running example app on my device says nothing about RX in any way. Neither error nor success. I also tried lorawan.set_device_class(CLASS_C); in the main function, but that doesn’t change anything.

Is that example meant to be used for receiving, at all? What am I possibly doing wrong here?

If you have a single channel gateway it will never occurs as it is a limitation, most of them does not support downlink messages.

As far as I know, these RAK Gateways are used in both ways. And why should the gateway show me a downlink message with frequency, SF and and with bandwith in the log, if downlink wasn’t supported at all?

it seems that the problem was actually anywhere on the network-server/application-server side. When I set up a new chirpstack-docker-stack, connecting my RAK gateway, it worked. So… no mbed problem here