Arm Mbed and Pelion Device Management support forum

Can't detect virtual serial port

Hey.

I’m trying to use USB Serial in a custom build hardware using mbed studio in a Windows 10. I’m compiling the Example [USBSerial_HelloWorld - main.cpp] for a NUCLEO-H743ZI.

After I installed the Mbed Virtual Serial Port by turn off the digital signature, I still have the error: This device cannot start. (Code 10)
I tried to update the driver using the same .inf file available at “https://os.mbed.com/handbook/USBSerial” and the following error shows up: " The folder you specified doesn’t contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for x64-based systems."

So I tried to install The Windows Serial Driver without success. Even though the device is plugged in the error: “No mbed Microcontrollers were found” keeps showing up.

I installed and re-installed the device. I re-installed the drivers and also changing the COM port number in the device manager advanced settings doesn’t work out.

Any ideas how to solve this issue? Thanks in advance

Ahoj,

  • Mbed Virtual Serial Port or the Windows Serial Driver are for original Mbed board, I think.
  • Use this page, your page is obsolete.
  • When the connection of USB is same like the on-board USB on Nucleo kits, you not need a special driver, Windows 10 will assigns standart Microsoft driver by it itself.
  • If you see, after you plug the USB cable, a COM port in Windows device manger it is OK.
  • I had similar problem on my NucleoF767ZI because I not understood how it working. The magic was correct setting of application what I used. You can check my old question where Jojo explained me how it works.

I hope it will help you.
BR, Jan

Thanks for your reply.
That’s exactly the problem. When I plug the USB cable the COM port is not detected by the device manager.
It is detected as USB but the device cannot start.

Ok, but I am confused now :slight_smile: , you wrote above

… and also changing the COM port number in the device manager…

Can you make a print screen of your device manager?

Sorry for not being so clear. Here it is.

Interesting.
I not see ST-link in your com ports. Do you have it already installed ST-link drivers?
And maybe uninstall all not used drivers what you install before.

Hi @andresa,

Have you been able to solve this problem? Reinstalling ST-Link drivers may help you solve this issue. Mbed Studio on Windows is installing ST drivers during installation process. You can install them again in case you deselected this option or uninstalled them.

You can find installer in either:

  • current user installation: {LOCAL_APPDATA}\Mbed Studio\mbed-studio-tools\stlink
  • all users installation: C:\ProgramData\Mbed Studio\mbed-studio-tools\stlink

Thanks,
Arek - Mbed Studio team