Mbed usb serial port not recognized

Can’t get an LPC1768 to show up as usb serial device on win10 (64bit) machine. The device is otherwise functioning. On connecting the usb cable, the device (mbed) is recognized as a mass storage device only. Using firmware #141212. Can anyone shed some light ?? Tnx !!


Fixed this. Reverted to previous firmware version and usb serial reconstituted.

This did not work for me. I tried reverting to two previous firmware and the device still showed up as a Mass Storage Device for both. I am currently running Windows 11. I have also tried to install the serial driver that was needed with Windows 7 but the link is no longer available.

Hi Madeline. I remember having to try several firmware iterations before finding one that reconstituted the usb serial port. I’ll look tonite and ID the one that worked for me. Frustrating isn’t it…


Got it whittled down to 2 possibilities. Apparently can’t append the firmware to forum posts. My email is zbelcas@charter.net. Reach out and I’ll send them to you.

This should be the correct driver: https://os.mbed.com/media/downloads/drivers/mbedWinSerial_16466.exe

It’s a little weird though, I had to copy the link and paste it into the URL bar in a new tab to get it to download. Suspect that Chrome is blocking it for some reason.

yup that’s it