Debugging old KL25Z program

Hi all,

Tl. Dr. : I have a code the board of the title, i installed all the required drivers on my PC but it keep reconnecting the “MBED” drive. On it I have the HTML file and a text file named “fail” saying “TIMEOUT”. I don’t have the source code, so I cannot re-flash it. What do?

Long version:
I was tasked to make an old (2015) PC software to work, but it doesn’t.
This software is supposed to communicate with a custom-made temperature comntroller based on the board listed in the title. The author of such instrument did not left a single word of documentation, so I don’t know nothing (not the setting used for the comunications between the board and the PC, not what is on the PC and what on the board, not how the two code exchange data, …). I cannot access the source code of the PC software to check anything (the software was made using LabView and I could not open the retro engineered VIs). The only informations I can retrieve are the board model (FRDM KL25Z from Freescale/NPX) and the firmware version (0203; latest is 0243).

Looking at the board I can say it is connected to the PC via the openSDA usb plug, and probably it’s also alimented using such port (but maybe also using a DC voltage).
After some testing, I can confirm that my PC can create a serial port, and open a connection trought it, but such connection last less than 1 minute. After that, the MBED drive and the serial connection keep resetting (like the USB cable was unplugged and plugged again) every few seconds. The MBED device at this point contain a second file called “fail.txt” with the text “TIMEOUT” written in it. I never tried to send any byte via this connection (since I don’t know what the board expect), but I tried to read the incoming data, but nothing was present.

The official documentation is very poor, and I cannot do any testing since I will loose the code on the board. Any help will be appreciated, starting for the meaning of the “fail” file: what does “TIMEOUT” mean? What’s timing out?

Thanks in advance,

Probably try updating bootloader… do this by putting board into bootloader mode etc.
This link is old so may need to search for latest updates etc.

For reference, it’s always worth looking at the hardware page… there is a section on firmware update etc.

I did not update the firmware because I was afraid I could loose the program, but I will try.
Thanks for the suggestion