Different results (online / mbed studio) for blinky baremetal example

I have tried the mbed-os-example-blinky-baremetal with NUCLEO-L053R8 target. But the results were different between online compiler (no error) and mbed studio (error with respect to default.lib). Both mbed-os libraries are at 5.15.1 version. How can I configure mbed studio to behave like online compiler.

Please understand our circumstances:

  1. We had several halt situations when teaching mbed in our classes while students tried to compile in online compiler simultaneously.
  2. We have to use STM32L0 which is expected to be used in WorldSkills competition.

Additionally, I have tested with NUCLEO-F401RE with similar results. No error for online compiler but link errors (HEAP) for Mbed Studio.

Error: L6218E: Undefined symbol Image$$ARM_LIB_HEAP$$ZI$$Base (referred from BUILD/NUCLEO_F401RE/ARMC6/mbed-os/platform/source/mbed_sdk_boot.o).


Hi @supachaiv,

I’ve checked that the output in the online compiler and Mbed Studio are the same for your target/library combination.
I suspect that the Mbed OS version you have in Mbed Studio is actually newer than 5.15.1 because the library file is pointing at a newer version:

To switch to the 5.15.1 release, please use the version dropdown in the library view:

Kind regards,