Nucleo-L053R8 not recognized when trying to compile blinky tutorial

Hi,

I’m trying to follow the first blinky tutorial using my Nucleo-L053R8 (which supports mbed). Please bear with me as I’m new both to arm and mbed. All I get from the compiler is Target "NUCLEO_L053R8" is not recognized.

I’ve tried to updated the firmware through this, but without any luck. I’ve also tried to change the mbed OS from v6.8 to other versions without any success. I am truly clueless.

1 Like

Hello,

this target seems to be not supported in MbedOS 6+ the reason is probably low RAM memory - 8KB.
Optimal was Mbed2 for this target but it is not maintained anymore.
So your last chance seems to be downgrade MbedOS to version 5.15.x

BR, Jan

Thank you very much Jan.

My mistake was not realizing that I had mbed OS as a filter.

EDIT:

Going through the different versions doesn’t seem to help. I get a mix of the same message and target does not support mbed OS X. This is how I thought I was supposed to change versions of the mbed OS. Please let me know if there is any big mistake being made or a workaround, because the tutorial given looks very much plug-and-play while at the end of the day is being very painful (at least for a beginner like myself)

Ah, my bad. I forgot to mention the Bare metal profile is necessary, for this low memory board.

You can try this blinky example.
GitHub - ARMmbed/mbed-os-example-blinky-baremetal: Bare metal blinky Mbed OS example

BTW the EDIT will not give me info about new content.

BR, Jan

1 Like

Dear Jan,

Thank you very much for the information (I did not understand the comment on the EDIT though).

I had to remove the "target.c_lib": "small" override on the .json file (for anyone who might stumble on similar problems and is very clueless like myself).

1 Like

Never mind.
The point was about I read your post before editing and not after.

Good luck
BR, Jan