Arm Mbed OS support forum

Import to compiler / download of repo always fails

Hi, I have a problem with the online mbed environment.

I am trying to clone a public repository ( this one: HKC_MiniCheetah - Fork of the Ben Katz's motor controller firmware. | Mbed ) into my Mbed compiler so that I can modify it.

However, when I try to import it into compiler, it always fails. I’ve tried multiple (20+) times. I’ve tried it at different times of day, I tried it two months ago and again today, still the same problem. What happens is the online compiler shows an “Importing” dialog for several minutes and then states that "An error occured while cloning the remote repository https://os.mbed.com/users/MartinGurtner/code/HKC_MiniCheetah/."

I also tried downloading the repository as zip or gz, with the intention of uploading it file by file afterwards to my compiler. Alas, this fails too - the zip/gz file starts downloading, but after approx. 36 MB of it are downloaded, the connection terminates. Again I tested this multiple times, the same thing happens every time. It seems to consistently fail at around 36MB data downloaded. The .zip file itself is about 50MB large.

I also attempted cloning the repo to the desktop ide, but that failed too.

Please, how can I clone that repository for my use?

Hello,

I think that issue is caused by old problem with download of mbed or mbed-dev. Do to ask me why and why it was solved, I do not know. The Mbed team is silent, and basically, the mbed2 is not supported anymore.
Another alternative is, the owner has no public programs in its profile - MartinGurtner | Mbed

Possible solution.

  • Create new project and try to download mbed-dev from here (it will take also some time) but I am not sure with compatibility of this version with version in the project. You must to try it.
  • Then create folder structure according to the project what you want to copy.
  • Whole project can not be downloaded but it can be downloaded folder by folder or file by file separately.
    Just open a folder or a file and download at as the .zip. This way you can download the whole project but without the mbed-dev.
  • Then upload all files into correct folders in your new project - Online Compiler support multi select drag&drop upload from PC to the browser.

Good luck
BR, Jan

Hi,

The import function of the online IDE is unstable if the repo has mbed-dev (mbed 2 source code).

You can import the marcurial repo from command line instead.

# import the code
$ hg clone https://os.mbed.com/users/MartinGurtner/code/HKC_MiniCheetah/
$ cd HKC_MiniCheetah

# copy mbed 2 tools
$ hg clone https://os.mbed.com/users/mbed_official/code/mbed-sdk-tools/ tools
$ pip install jinja2 jsonschema pyelftools fuzzywuzzy

# build the project
$ mbed compile -m nucleo_f446re -t gcc_arm

I hope this helps.

Toyo