Increase consistency of source code

I just checked the source code for a few minutes and I am not very excited what I read.

So far I assume there are missing guidelines about code readability/understandability, consistency and transparency.

It really would be nice if this could be increased.

E.g if there is a kernel function critical_section_enter(), and there is a lightweight wrapper, it should be named “enter”, and not “enable”.

1 Like

I think it’s better to raise issues on Github for this kind of things and provide PR implementing the changes. This way the changes can be discussed with the dev team (which is very responsive!) and the PR can be merged quickly so that everyone can benefit from it! :slight_smile: