Arm Mbed OS support forum

MAX32630 USBMSD driver not found

Hi there,
I’m working with a MAX32630 with a MX25 nand memory and Mbed OS 5.15.6.
I want to create a USBMSD device to get access to mass storage.
I manage to compile but once I run the code I get the followinf error :

https://mbed.com/s/error?error=0x80FF0100&tgt=“MAX32630”
– MbedOS Error Info –
This board does not have a hardware USB driver

Could someone help me with that.

Thank you

Hello,

I do not know if the USB DEVICE is supported on Maxim’s targets or not, but usually the USB DEVICE is not active in default.
When you check the target.json file for MbedOS 5.15 there is no USBDEVICE in the list.

You can try to add it via mbed_app.json file, with something like this content.

{
    "target_overrides": {
        "*": {
            "target.device_has_add": ["USBDEVICE"]
        }
    }
}

In the MbedOS 6.7 it was added in default configuration, so you can also try it with latest MbedOS and without the configuration via mbed_app.json file.

BR, Jan

Thank you for your answer,
I tried adding and I get a new error :
[ERROR] BUILD/MRD103/GCC_ARM/mbed-os/drivers/source/usb/USBMSD.o: In function USBMSD::USBMSD(mbed::BlockDevice*, bool, unsigned short, unsigned short, unsigned short)': .\mbed-os\drivers\source\usb/USBMSD.cpp:70: undefined reference to get_usb_phy()’

I tried many things to get past that problem but I just can’t find the solution.

For the moment I can’t change the mbed version but I will definitely do so when I can.

@batoutou123
The USB stack implementation for the MAX32630FTHR broke somewhere around OS 5.10 if i remember right and has only been reimplemented for this target in the OS 6.7 release. So you either need an ancient OS release or a recent one for your purposes.