MBED_ARM_PATH set as environment variable but doesn't exist


I use this to compile the basic blink code but i doesn’t works :

mbed compile -t GCC_ARM -m K64F -f --sterm

But it result in a “MBED_ARM_PATH set as environment variable but doesn’t exist”

The thing is I’m not using ARM_PATH but ARM_GCC_PATH which has been set previously with a
mbed config -G GCC_ARM_PATH /Users/antoine/Documents/Dev/gcc-arm-none-eabi-6-2017-q2-update/bin

What’s wrong ?

Hi Antoine,

Mbed CLI will check all the configuration, so if MBED_ARM_PATH is set, it is checked as well.

Try to use mbed config -U MBED_ARM_PATH to unset the config.


Hi, thanks for the answer. Unfortunatly it doesn’t change the error. Here is what happens :

    antoine@MacBook-Pro-de-Antoine-2 mbed-os-example-blinky % mbed config -U MBED_ARM_PATH                          
    [mbed] Unset default MBED_ARM_PATH in program "mbed-os-example-blinky"
    antoine@MacBook-Pro-de-Antoine-2 mbed-os-example-blinky % mbed compile -t GCC_ARM -m K64F -f --sterm            
    [mbed] Working path "/Users/antoine/Documents/Dev/Mbed/mbed-os-example-blinky" (program)
    WARNING: MBED_ARM_PATH set as environment variable but doesn't exist
    Traceback (most recent call last):
      File "/Users/antoine/Documents/Dev/Mbed/mbed-os-example-blinky/mbed-os/tools/make.py", line 37, in <module>
        from tools.tests import TESTS, Test, TEST_MAP
      File "/Users/antoine/Documents/Dev/Mbed/mbed-os-example-blinky/mbed-os/tools/tests.py", line 20, in <module>
        from tools.targets import TARGETS
      File "/Users/antoine/Documents/Dev/Mbed/mbed-os-example-blinky/mbed-os/tools/targets/__init__.py", line 32, in <module>
        from tools.psa import find_secure_image
      File "/Users/antoine/Documents/Dev/Mbed/mbed-os-example-blinky/mbed-os/tools/psa/__init__.py", line 23, in <module>
        from .generate_partition_code import manifests_discovery, generate_spm_code
      File "/Users/antoine/Documents/Dev/Mbed/mbed-os-example-blinky/mbed-os/tools/psa/generate_partition_code.py", line 28, in <module>
        from tools.psa.mbed_spm_tfm_common import validate_partition_manifests, \
      File "/Users/antoine/Documents/Dev/Mbed/mbed-os-example-blinky/mbed-os/tools/psa/mbed_spm_tfm_common.py", line 21, in <module>
        from jsonschema import validate
      File "/Users/antoine/Library/Python/2.7/lib/python/site-packages/jsonschema/__init__.py", line 33, in <module>
        import importlib_metadata as metadata
      File "/Users/antoine/Library/Python/2.7/lib/python/site-packages/importlib_metadata/__init__.py", line 15, in <module>
        from ._compat import (
      File "/Users/antoine/Library/Python/2.7/lib/python/site-packages/importlib_metadata/_compat.py", line 19, in <module>
        from backports.configparser import ConfigParser
    ImportError: No module named configparser
    [mbed] ERROR: "/System/Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python" returned error.
           Code: 1
           Path: "/Users/antoine/Documents/Dev/Mbed/mbed-os-example-blinky"
           Command: "/System/Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python -u /Users/antoine/Documents/Dev/Mbed/mbed-os-example-blinky/mbed-os/tools/make.py -t GCC_ARM -m K64F --source . --build ./BUILD/K64F/GCC_ARM"
           Tip: You could retry the last command with "-v" flag for verbose output

Still the same error. weird

Should use global config mbed config -UG MBED_ARM_PATH.

But it seems not the reason causing ERROR, the reason is ImportError: No module named configparser. You should install that package.