Mbed forum

Mbed compiler compile problem


(Roelof Doevendans) #1

So i received my LPC4088 with the 5" display module and i’m trying to compile and flash one of the example programs but i can’t compile any of the example programs succesfully. I constantly get the same error for every example program. I assume the code is fine but somehow it gives errors i cant seem to fix without having to dive very deeply into the code. Is it because i’m missing something?

https://os.mbed.com/platforms/EA-LPC4088-Display-Module/


I first got a dm_board_config.h which was caused by the name of the file having a .txt extension.

Also when importing the display module shipped demo project it gives me an import warning and won’t let me compile the code as it misses mbed.h. After importing the whole C/C++ SDK library this is fixed, but an endless train of code errors appear.
image


(Ralph Fulchiero) #2

Hi Roelof,

Unfortunately we think all these projects are being impacted by an Online Compiler build problem with include paths as described here:

The projects seem to be based on a version of Mbed that was short-lived (post OS2) and they haven’t been migrated to OS5 so that has compounded the problem due to the folder structure that was used.

We were able to get the Hello World program to build by moving dm_board_config.h into the DMSupport folder:

We also tried taking these to the command line tools (CLI), but encountered another issue based on how the examples are packaged. If you revert to an old version of the CLI tools, you might be able to get them to build.

Could you try relocating dm_board_config.h for the Hello World example to confirm that builds for you?

Sadly there has been no updates to these examples in over 3 years and we haven’t found any community members that have moved them forward.

Regards,
Ralph, Team Mbed


(Roelof Doevendans) #3

Hello Ralph,

I can confirm that the Hello World program is working using the method of replacing the dm_board_config.h!
I have also tried this for some other projects and i can also confirm that this method works for the following projects:

image

As for the other display projects, it’s not working.

And one last question, is there any way to export the projects to MCUXpresso? I have tried this but MCUXpresso is greyed out sadly…