Arm Mbed OS support forum

Mbed online compiler problem - compilation needed after long time

I have problem with compiling my old project made back in 2014. I was compiling it recently in about february 2019. No I can’t compile it because of problem
“Error: Fatal error: C3903U: Argument ‘Cortex-M4.fp.sp’ not permitted for option ‘cpu’.”
Additionally I can’t export it to normal IDE or import it in MBED Studio from link to repository.
Any suggestion how to overcome this issue?
Best regards

1 Like

Hey, might need to revert mbed version to a lower one… In version control.

Sorry, I am new on embed os and I am trying to work with provided components library of dht22. but I am getting the same error. I don’t know how to check and change mbed version. please help me with this.

I guess the dht22 library you are playing with has been written years ago, maybe for mbed OS 2 and not for 5. (But that is not easy to tell as no libraries are sorted based on the mbed version they were written for…)
If it is for v2, you surely can not use it with Mbed Studio as the lowest mbed-os version that this IDE supports is V5.12.

I am sure in the online compiler one could select also ancient version of mbed-os before by clicking on the “mbed-os” library in the active project and then by clicking the “Revision” (placed top center on the menu bar). That way you could see a list with mbed versions like V5.4 etc. before. Tried the same right now and the latest selectable version is V5.13. So there must have been a decision to drop old versions even from the online compiler.

For sure there is even the command-line version of embed which is cumbersome to use but many tell that is the most advanced mbed-os tool. So that might be your last chance for using older mbed os than 5.12. However maybe even that might have dropped support for older mbed version by now.

Hi Peter,
I solve the problem by removing and reimporting the mbed library. however, I felt that at least official examples should be updated. and this kind of errors must be mentioned in documents as it is frequent, so that it would be friendly for beginners. Btw thanks for the details.

Well then it is not a bug, but a feature.
Meaning it will not be fixed, nor documented :joy: