Arm Mbed OS support forum

MBED Studio 1.3.0 can't create new project if no internet connection

Hi, on MBED studio 1.3.0 i’m facing an error when I try to create new project when I’m not connected to internet.
I’m attempting to create a project with shared OS. This works only if I have internet acces, otherwise I’m facing an error message concerning github connection pon port 443 and project creation is not complete.

I need to work with no internet connection because I’m a teacher and in my school internet acces is filtered.
Prior to versions 1.0 i have no problem to work offline.

My config :
windows 10 pro 2009 on my computer, windows 7 pro on school computers.

Thanks for your interest, sorry for my poor english but I’m french.
JM SEGURET

EDIT : This seems to occurs ramdomly … I re-run MBED Studio 30mn later and it works on my computer… Library pipeline and library cache aren’t populated when i have tried to create new projet…

But what is the reason for use cache and pipeline (git) when creating a project witch target shared OS ? The entire OS is in the directory … and i d’ont want to update the directory content For an “offline tool” it’s a bit disappointing … I appreciate to have an option to turn off git use…

Hi @jm_seguret,

Thank you for reporting this issue. We will look into this issue closely. I confirm that this use-case is designed to work fully offline. We will check if it is a regression and fix it as soon as possible.

Thanks,
Arek - Mbed Studio team

Thanks for your interest.
I have used all versions of MBED studio since 0.4 … A lot of progress were done.

I have another remark (not a bug, just a remark) when I choose to make install “for all users”, MBED studio install files in “programs” folder on windows, it’s great but library cache and library pipeline sits in appdata user folder … And every new user that use MBED studio will consume approx 1Gb of disk …

I’m sure you cannot process otherwise for write rights in windows “programs” folder., but maybe it’s possible in “programdata” folder .

Thanks.
JM SEGURET