Mbed Studio 1.4.2 linter bugs

We are also having problems. All worked OK on 1.4.1 but after update Studio to 1.4.2 Lint cannot find many header files (such as stddef.h, stdint.h and so on). Same question: where to find older version installation or what have to be done to solve this problem on updated version??? Big project has stopped… If we do not have any solution in a short time we will have to change IDE to some other one…

Hello, I happen to have the Mbed studio 1.4.1 installation executable saved on my machine, for you looking “revert” I guess the best option would be to uninstall 1.4.2 and install 1.4.1 instead, and then just never clicking the update prompt. I am not sure if posting download links is allowed, but see the link below for a download.


Hello, before taking the decision to uninstall and switch back to version 1.4.1 provided by Tijn_Losekoot I tried different things including a clean build.
And this clean build solved my Error: L6218E.

1 Like

When I build/clean build my system I get the following messages

However, the compile completes without any errors. I am unable to test this code on my hardware at this time so cannot tell if there are any issues.

Should I just ignore these problems?


Jim Herd


I am using Mbed Studio under Ubuntu 18.04 and I have the same problem as you


Hi everyone,

The Mbed Studio team are investigating the issues reported with C/C++ support in version 1.4.2. This is most likely caused by the upgrade from Arm Compiler 6.15 to 6.16.

Apologies for any inconvenience, we’ll keep you posted on the fix.

If you are affected by this issue, you can roll back to the old release:

  1. Uninstall 1.4.2
  2. Download and install 1.4.1 for your platform: Linux Windows Mac
  3. Ignore any tools updates until a fix is available



Thanks for the links to the older versions.
I figured out the link for v1.4.0
Now at least i can revert back to that version and get rid of the linting errors and also have my printf and friends function properly which have been broken since v1.4.1

I’m having a similar problem with the linter, although I’m using gcc as the compiler. Maybe it’s also an issue with clangd?

Hi all,

We’ve just released Mbed Studio 1.4.3 with fixes for the C/C++ language support with Arm Compiler.

The new version is live on Mbed Studio | Mbed and will be rolling out over auto-update in the next few days.



I just downloaded and installed Mbed Studio 1.3. I’m still having the same linter issues.

Note that I’m using gcc instead of the ARMCC.



-Dan Fay

I’m seeing similar issues with Intellisense in Mbed Studio 1.4.3 where say int32_t and bool are flagged up as being ‘Use of Undeclared Identifier’ in the editor (using clang?), Intellisense with both stdint.h and stdboo.h included. The code compiles fine with the default (Arm?) compiler tool chain.
I only see the issue if the file I’m compiling is a .c file. If I change the suffix to .cpp to invoke the compiler in C++ mode with C++ includes then the intellisense issues go away.

I am still seeing the same problem with 1.4.3 and GCC 9 2020-q2-update
I am using a Nucleo F429ZI

Using the latest Mbed Studio version (1.4.3) I no longer experiment the described issues. Thanks for the fix!

I spoke too fast… After the latest update I’m getting the following error when compiling for a NUCLEO-F103RB target:

	"resource": "file:///c%3A/Users/user/Mbed%20Programs/project/main.cpp",
	"owner": "file:///c%3A/Users/user/Mbed%20Programs/project/main.cpp",
	"code": "pp_hash_error",
	"severity": 1,
	"message": "In included file: \"Compiler generates FPU instructions for a device without an FPU (check __FPU_PRESENT)\"",
	"source": "clang",
	"startLineNumber": 5,
	"startColumn": 9,
	"endLineNumber": 5,
	"endColumn": 17

Just for info
Updated libraries now get Error about FPU Nucleo f103rb - Mbed OS - Arm Mbed OS support forum

BR, Jan

1 Like

please post the solution for printf like issue

Hello @mgordon01,

Is there any update of this bug?

I am still having the same issue: false intellisense report when using GCC.
Eg: In included file: 'stdint.h' file not foundclang(pp_file_not_found)


Build and flash works, but Intellisense keep throwing errors.


EDIT: Same intellisense errors using GCC 9 2020-q2-update as written here.

EDIT2: I confirm that rolling back to MbedStudio 1.4.1 make intellisense work again with GCC.

EDIT3: The website documentation has been update recently (March 1st), new recommended version is GCC 10.3-2021.07. Intellisense still not working with this version of the toolchain.

Still not working using new version of Mbed Studio (1.4.5) :


That does not surprise me in the slightest. Two years on, some things still are not fixed. See this post here for instance: https://forums.mbed.com/t/target-restrict-size-doesnt-pad-out-the-bin-file/14553/3. Simply ridiculous.

The fact that I am still getting notifications from this forum two years after last working with this despicable piece of software, says a lot to me.

If you are thinking of using the bootloader feature of Mbed OS, do not bother, that’s all.

Kind regards,

Tijn Losekoot

Target.restrict_size doesn’t pad out the .bin file
I use target.restrict_size like so in the mbed_app.json file. { “target_overrides”: { “MAX32630FTHR”: { “target.device_name”: “MAX32630”, “target.bootloader_supported”: true, “target.pad_to_restrict_size”: true, “target.restrict_size”: “0x16000” } } } I even added the extra parameter “pad_to_restrict_size” after coming across this old Github post: Add padding up to restrict_size by statropy · Pull Request #11043 · ARMmbed/…

  • | - |

======================================================================================================================================== E-maildisclaimer: Aan dit bericht, waaronder ook de eventuele bijlagen worden bedoeld, kunnen geen rechten worden ontleend. Dit bericht is uitsluitend bestemd voor de geadresseerde en bevat persoonlijke en vertrouwelijke informatie. Het bekend maken, kopieren en verspreiden van een bericht dat niet voor u bestemd is, is niet toegestaan. Als u dit bericht per ongeluk heeft ontvangen, verzoeken wij u vriendelijk het direct te vernietigen en de afzender te informeren. Twijfelt u over de juistheid of volledigheid van dit bericht? Neem dan contact op met de afzender. ======================================================================================================================================== This message and any associated attachments cannot be deemed as legally binding under any circumstances. This message is intended for the exclusive use of the person(s) mentioned as recipient(s) and contains personal and confidential information. Directly or indirectly copying, disclosing, distributing, printing, publicising and/or in any way using this message or any part thereof by any means is strictly prohibited if you are not the intended recipient(s). If you have received this message in error, please notify the sender and delete this message from your system immediately. If you are in doubt regarding the correctness and/or completeness of this message, please contact the sender.

Hello @Tijn_Losekoot,

Thanks for the input,
Indeed I think you’re right.

The fact that linter/IntelliSense doesn’t work correctly with GCC (and with custom targets) is a major drawback for us.

I liked the idea to have an “out of the box” IDE to instantly play with MbedOS.
It’s a good way to easily introduce the software to students or collaborators.

Unfortunately, MbedStudio is not usable for us in its current state.
And I do not want to use the online “Keil Studio Cloud”.

So right now, among solutions to write code for MbedOS, we mainly use VSCode after typing mbed export -i vscode_gcc_arm in the root of the project.
Clion is also an excellent IDE using mbed export -i cmake_gcc_arm.
But in both cases, people must be comfortable using mbed in command line for compiling or uploading.

The following is off-topic:

Additionally to the post you provide, I still don’t understand why “Mbed CLI 1” was frozen, when “Mbed CLI 2” (or mbed-tools) is still in beta, and rarely updated (Last true closed issue: september 2021. Last merged PR: 1 year ago. Last real repo update: 1 year ago).
We’re still using Mbed CLI 1, even with MbedOS 6.17, and fortunately it still works great (provided you use a .mbedignore file to accelerate building).

Generally speaking, as said in previous post and messages on this forum (here, here, here … ), MbedOS development seems to be on hold. And it is difficult to seek a clear response from arm about the future of the software.

A lot of people are using Mbed, it’s an “easy” embedded OS, a big step from Arduino, but not as big as moving to Zephyr (for example). It’s a good in-between, It would be a shame if arm stop working on it. Nevertheless, MbedCE seems to be a promising community fork/evolution.

Best regards.

1 Like