Mbed studio for GD32F30x

I’m working on a project using gd32f303cet, I’m trying to turn on the LED, I want to program it using Mbed Studio but there is no target option for gd32f303cet, I tried using the gd32f307VG target but it still won’t work, I’ve tried changing the library in it to make it compatible with gd32f303cet but the results still don’t work, and I’m trying to export the code to Keil uvision using command “mbed export -i uvision5 -m GD32_F307VG” but it didn’t work the error say it didn’t support uvision5 or 6. I also tried a custom board but the result still wasn’t the same. What do you think I have to do to be able to program it on Mbed Studio?


  • trying to export is a waste of time from my point of view, it is not maintained for years.
  • “Not working” is not optimal decription of any issue.
  • I am not sure there will be someone who is familiar with GigaDevice boards. But some addition information like - it is custom board or it is just another dev board? What a debugger do you use? What clock settings do you have (HSE/HSI)?

GD32F303CET6-Arm Cortex-M4-GigaDevice Semiconductor Inc.
GD32F307VGT6-Arm Cortex-M4-GigaDevice Semiconductor Inc.

  • First what we can say is these MCUs have diffrent memory sizes of MCU Flash and Ram. So you definitely have to change settings in its linker.
  • Both MCUs have diffrent number of pins so also its perioheral and pin map settings have to be changed.
  • Also Clock settings could be a problem because of different clock settings - probably here
  • For sleep (wait) function is important correct settings of system ticker

BR, Jan

hello, I want to ask you something i opened an example project in Mbed Studio i opened target gd32f307vg but there is an error like this

is that normal? because the first time I installed the mbed studio I used the example blinky led, in the target board for gd32f307 every code that has uint32_t is always an error. if I compile the example there is no error.

and thank you so much for your answer.

Sadly it could be normal, in case of Mbed Studio. It depends who report this error. If you see in Error window (I do not remember correct name I do not use MbedStudio) after the error description something like (clag...) and you do not see or can not found relevant reason of this then you can ignore this.

BR, Jan

May I know what IDE you use for hardware development?

In case of Mbed I use KeilStudio Cloud because development of MbedStudio was stoped and continue here. In unknow future will be released KeilStudio Desktop that replace MbedStudio.

Last few months I use MbedCE with VS code.
[Help Wanted] Mbed CE: A community fork of Mbed OS - Mbed OS - Arm Mbed OS support forum

BR, Jan