Mbed Studio IntelliSense sometimes brakes after adding mbed_app.json file?

Hi there!

After I added my mbed_app.json file to my active project, for some reason the Mbed Studio IntelliSense no longer functions normally. This is only the case with projects that don’t have mbed_app.json file aready included. Imported projects that already have had mbed_app.json file will cause no problem.

Bug? Any fixes?

Hello Denial,

if your topic is related to MbedStudio’s potential issue, then be so kind and use section for Mbed Studio and not for MbedOS.
Also would be good to be more specific with description of problem you are facing - printscreen or something.

I tried to reproduce your potential issue:

  1. I created a new bliky example from MbedStudio templates with full profile of MbedOS
  2. Update MbedOS to latest
  3. I created a mbed_app.json file with bare metal profile settings
  4. Build - Intellisense and compilation seems to be OK.

In addition there were nothing change in Mbed Studio for last few months.

BR, Jan

Hi both,

This sounds similar to the bare metal issue reported by @JohnnyK in Mbed Keil Studio Cloud IntelliSense "fake" (invalid) errors and header problems (mbed.h error) - #6 by JohnnyK.

If so, my suggestion here might work around it: Mbed Keil Studio Cloud IntelliSense "fake" (invalid) errors and header problems (mbed.h error) - #8 by mgordon01.


1 Like

Hi there,

I tried you’re work around solution. Deleted the mbed_config.json file, switched to random empty project and than switched back to the project in use, remade my mbed_app.json file and finally I decided to restarted Mbed studio. After which, the IntelliSense is working again!

Although I mark you’re answer as the solution for this topic, I believe this wasn’t the “true” solution and my reasoning is the inconsistency of this problem and it’s solutions. I believe I’ve had encountered this problem before and did similar steps, but not always achieved similar results. Sometimes it randomly resolved itself. Sometimes a simple restart of Mbed Studio worked. Sometimes switching back and forth between projects helped.

And sometimes, like in this case, the solution wasn’t as clear as before (I’m still not sure what step really did solve the problem). I do not know how common these IntelliSense related problems are, but at least in our home University, this is a relatively frequently encountered problem and causes a lot of confusion with lesser experienced students and developers. I really hope these issues are also eventually fixed.

If this is as frequently encountered problem as it seems, shouldn’t this be included in “Known issues” of the official documentation of Mbed Studio?

An off topic question regarding the mbed_app.json file, is there an official explanation on what it does, and how is it ment to be used?

Best Regards,

Hi there Johnny,

the problem is somewhat inconsistent, meaning it doesn’t show up in any meaningful pattern(or at-least I haven’t noticed if it shows up after certain steps/events). I changed the topic to “Mbed Studio IntelliSense sometimes brakes after adding mbed_app.json file?”, because, quite literally this is the problem I have faced/facing.

Could not think of more descriptive description of the problem, as it is somewhat inconsistent problem that occurs in different circumstances and I at-least have found different general solutions for it. (except this time, thus bringing me here to forums)

Best Regards,
Danial Mousavi