Mbed Studio, Nucleo L432KC not printing to serial monitor

IDE: MBed Studio 1.3.1
MBed OS: 6.7.0 (shared library across several projects).
Target: Nucleo L432KC

We are experiencing issues with printing to the serial monitor (and event external terminals like TeraTerm) through the USB connection. Programs that once worked will eventually produce no serial output. It seems as if changes in newly compiled programs are not reflected in the .bin file. We can take the same program and move to another PC with Mbed studio, compile, and it runs okay. We have yet to fine the exact procedure that causes this issue.

We have tried reconnecting device and clean builds. We ensured L432KC firmware was updated.

We are wondering if others have observed similar issue.


I am using L432KB with mbed-os 6.15. I encounter a similar problem as yours.[Mbed-os 6.15 UART BufferedSerial and UnbufferedSerial not work on L432KB - #2 by JohnnyK](https://forums.mbed.com/t/mbed-os-6-15-uart-bufferedserial-and-unbufferedserial-not-work-on-l432kb
Please let me know if you find a answer.