My mbed is NOT recognized by my PC

My mbed is not recognized as a port by my PC. Instead, it is recognized as a portable device. I want to do serial communication with Tera Term. I know win10 doesn’t require serial driver installation. Please someone solve this problem.


that’s not too much information

your “mbed” is LPC1768? What did you already tried?

BR, Jan

Hello Jan

・My PC OS : Windows 10 Home
・My mbed : LPC1768
・My using teminal : Teraterm
・What i already tried :
(1) I can compile from pc to LPC1768 and run some program
(2) I wanted serial communication to get the value of the 9-axis sensor with mbed
(3) But my Teraterm does not recognize my mbed
(4) After investigating, I found that win10 does not require the mbed usb driver
(5) But device manager shows my mbed as portable device

Please let me know if you find out…

  • Connect the USB cable directly to USB port of your motherboard, not to a front panel.
  • There were an issue on WIn10 I think, so if you have still old firmware… this could be also handy - Firmware LPC1768 LPC11U24 - Handbook | Mbed
  • Check if some device was not recognized via Windows device manager

If steps above does not help and you have a laptop with Win10 Pro, then connect the usb cable to the laptop. I’ve never worked with the Win 10 Home, but I remember from older Windows versions, that was always pain to work with Home edition when you want to do something more. You will see if something change.

BR, Jan

To help us reproduce and fix the reported issue, please attach the Mbed Studio log files to your report:

From the Help menu, select Report an Issue. This opens the Report an issue or provide feedback dialog box.
Click Access Log. This opens the folder that contains the Mbed Studio log files.
Attach the mbed-studio.log and mbed-studio.log.1 files to your email.

Rachel Gomez