Arm Mbed OS support forum

No avaible serial com in tera term

Hi guys,

I have a problem with tera term I’m using STM32F100RB and ı want to display with tera term using uart protocols.But i couldnt click serial com. I tried to install mbed win serial but i connected my microcontroller buta still it has error for “microcontroller were not found”. How can i fix this ?

Maybe you need to install the ST-Link USB driver: STSW-LINK009 - ST-LINK, ST-LINK/V2, ST-LINK/V2-1 USB driver signed for Windows7, Windows8, Windows10 - STMicroelectronics

I installed but it’s still not working.

Do you see anything in Device Manager when you plug it in (esp. under USB and COM ports)?

No i cant see

Actullay its major issue for me i cant see any com ports and i tried to click to legacy hardware and i choosed to COM ports and ı have another error for code 10.

Sounds like you have either a dead board or a bad USB cable

but i can import code from st utility and its working when ı dont need to serial com.

Ah, I see. Looking at the schematics, I don’t think your board actually has a USB-serial adapter built in. I think you’d need to connect another adapter, such as an FTDI friend, to the UART pins on it.