Arm Mbed and Pelion Device Management support forum

Please fix the export from the online compiler

Please mbed support. Try to fix all the issues exist in the online compiler.
None of the export from the online compiler works for me when I export to (eclipse, or GNU MAKE).
I reported this issue before but nothing happens.

for example:
Each makefile I get from the online compiler contains this line

ASM_FLAGS += /filer/workspace_data/exports/0/0b56195140e36b1c83f4483fb903ae8c/NucleoBT_Module_copy/mbed_config.h

which is obvious that it should be like this
ASM_FLAGS += . . /mbed_config.h

Other issues I have, the export is not complete … It dosen’t compile sometimes… It is missing header or other files inside the makefile …etc
Many many issues that I cannot write down them all. So, please you need to use by yourself the online compiler and try to compile your code. Take a project with multiple library so you see the problems.

I hope you fix these issues … They have been there for a loooooooooong time … and I think it is time to fix it pleasesss!!

Using mbed-cli dosen’t work either … what are these problems?

[mbed] Updating library “mbed” to rev #34e6b704fe68
[mbed] Downloading library build “34e6b704fe68” (might take a while)
[mbed] ERROR: OS Error: The process cannot access the file because it is being used by another process

So, I am stuck here … I cannot compile my project, I cannot download, I tried to import mbed-dev … it dosen’t work either it generates “Gate time out …etc”

Thank you for raising this issue and apologies for the inconvenience. We are aware of the exporter problems, but we are unable to provide a short term fix. We are working on medium term solution to exporters alongside other performance and reliability improvements.

We have occasionally seen mbed-cli issue you mention and suspect it to be caused by a slow internet connection timing out and mbed-cli leaves a lock file in place. Could you please try the following command and let me know if it resolve the issue:

mbed cache purge

Thank you for your reply.
No, I tried everything … It dosent work.
I get the same issue. Other libraries downloads ok but not the mbed. 2

I know you shouldn’t have to do this, but have you tried pulling your project into a fresh installation of mbed-cli, i.e. in a different location on disc?