Problem updating a BLE ReadWriteCharacteristic

Dear Forum users,

this is my first post here in the Forum so thanks in advance for your help.

I’m facing a strange behavior in my Code, in which i try to update a ReadWriteGattCharacteristic in BLE in the online compiler. I tried to run it on a custom NordicSemiconductor nrf51822 Board as well as on the NRF52DK, same behavior, so i think it is related to the platform.
I’m running classic mbed and the following code won’t work:

this->numberOfCurrentSessionMeasurements = 0; //this is a uint8_t class variable setting works
BLE::Instance(BLE::DEFAULT_INSTANCE).gattServer().write(this->numberOfSamples.getValueHandle(),(uint8_t *)&numberOfCurrentSessionMeasurements, sizeof(uint8_t), false); //this line gets called but the GattCharacteristic is never updated, this worked before, might this be

Am i missing something or what is the problem?

PS: sorry for the mbed_os tag, but there were no better options to tag it :slight_smile:
Any help is appreciated

best regards