Problem with running MBedStudio 1.4.5 and 1.4.6 install scripts on Debian 12 Bookworm


In trying to install MBed Studio for the first time, I just tried to run the following command in Konsole with the result shown.

$ sh 828: Syntax error: word unexpected (expecting ")")

Nor being familiar with Bash programming, I tried to run the updated installer with a similar result.

$ sh 828: Syntax error: word unexpected (expecting ")")

Is there an edit I can perform on line 828 of either install script that will allow the script to successfully install MBed Studio ?



As the 1st line of this script says, it reuqired bash rather than sh.

$ bash

Or, run this script by adding execution attribute.

$ chmod +x ./
$ ./

Good morning MACRUM,

Thank you for your reply. Yes, I do have Bash installed. The second line of the script that you supplied (thank you!) is the way I did eventually go. After posting to this forum I then then(!!) :frowning_face: found the install support on the Documentation section of this website. Is my face :hot_face: !

Thanks again for your help.