Arm Mbed OS support forum

Switching from AC6 to GCC

Hi,

I’m using Mbed studio for the first time, I observed Mbed studio is using AC6 as default and i need to work on GCC, so i tried to switch from AC6 to GCC by following steps as mentioned in the below link, but program is still compiling using AC6, could you please help me resolving this issue.

LINK : Switching to GCC - Installing | Mbed Studio Documentation

Hello,

I trid that few weeks ago and it was working on Windows10.
Did you install the GCC before?

BR, Jan

Hi,

Yes i have installed GCC in my system, though I’m using windows 11

PFA for your reference

Yeah, same issue here. However, i managed to work around it by:

  1. Install 9-2020-q2-update-win32.exe

I had previously installed 9-2019-q4-major-win32.exe. It was working well, but Mbed Studio was unable to recognize it even though I added the full path to external-tools.json.

Don’t know if it was the Install itself that fixed it, or if it’s that Mbed studio fails to recognize any other version of GCC than the specified here: Switching to GCC - Installing | Mbed Studio Documentation

Hi,

Thanks for your reply.

In this link : Switching to GCC - Installing | Mbed Studio Documentation

they spoke about switching from ARMC6 to GCC by manually creating extern-tools.json file however that didn’t work for me, so i found work around

Work around:
under Mbed studio/tools-config make changes to extern-tools.json file manualy

i have replaced default deceleration with the changes as mentioned below

“defaultToolchain”: “GCC_ARM”,

“gcc”: “C:/Program Files (x86)/GNU Arm Embedded Toolchain/9 2020-q2-update/bin”,

Thanks