The mbed tools were not found in <Porject PAth> error on ubuntu

I trying to compile project: , which was created by mbed. I worked with kws_realtime_test project for STM32F746NG board. I m trying to compile on Ubuntu machine in command line.

I made step by step everything by the attached file, from an above mentioned project.

When I call mbed deploy, than I get a warning message:

[mbed] WARNING: Cannot find the mbed tools directory in “/home/alessandro/Scrivania/ML_KWS/Deployment/kws_realtime_test”

And when I try to compile than I get an error:

[mbed] ERROR: The mbed tools were not found in “/home/alessandro/Scrivania/ML_KWS/Deployment/kws_realtime_test”
You can run “mbed deploy” to install dependencies and tools.

On some forum I read, that I need to add mbed-os to my project

When I add that, I can deploy the project without any warning, but I have an error after compile:

[ERROR] Library name ‘platform’ is not unique (defined in ‘“/home/alessandro/Scrivania/ML_KWS/Deployment/kws_realtime_test\mbed\65be27845400\TARGET_DISCO_F746NG\TOOLCHAIN_GCC_ARM\mbed_lib.json’ and “/home/alessandro/Scrivania/ML_KWS/Deployment/kws_realtime_test\mbed-os\platform\mbed_lib.json’)
[mbed] Working path “”

I tried to remove one of .json files, and the compilation finally can start, but after 10% I get many compiler errors. My compiler cant compile source files from mbed-os directory. Im using GNU GCC compiler.

  • So how can I compile that project?
  • Why I need mbed-os to my project? It is not mentioned in readme file. Is it not enough to install mbed-tools, and no whole mbed-os? I think my project do not use any OS functionality.

I 'm working on a compilation of a simple project few days, and is going to be a really nightmare for me.

Are there any simpler way to precompile this project?

I have already seen at but the solution proposed not solve my problem