Arm Mbed OS support forum

"The mbed tools were not found in <Project Path>" error on Ubuntu

Hi,
I have just started with mbed OS on linux. I manually installed as indicated on https://os.mbed.com/docs/mbed-os/v5.15/tools/manual-installation.html.
I cloned the blinky project and tried to compile it using mbed cli using the command as shown


But the error “The mbed tools were not found in …”. The paths for the compiler as set as per the guide.
Am i missing something?

Hi, could you try mbed compile --source ./mbed-os ?

Hi Desmond,
I tried the command but I get the same error.

Hi, you need do mbed deploy before compiling the code, because the project only has mbed-os.lib in it, instead of the code of Mbed OS, I missed the ERROR part of your log.

mbed deploy does not fix the error

For anyone who runs into this issue, please check your MBED_OS_DIR

mbed config MBED_OS_DIR

At one point I changed the global os folder then renamed that folder, and ran into this issue weeks later. After unsetting global MBED_OS_DIR, I was able to compile my projects as usual.

mbed config --global MBED_OS_DIR --unset

Hope this can help some poor soul.