Arm Mbed OS support forum

Unexpected restart of NUCLEO-L432KC

Hello,

I want to use a NUCLEO-L432KC as an interface card on a computer.
The L432KC reboots when it is plugged into the USB port of my computer in Windows 10.
These restarts occur randomly after a few minutes.
These restarts also occur if I supply it with 12V and it is connected to the USB port of the computer.
I did not observe these restarts when the L432KC is powered without being plugged into a USB port.
I did not observe these reboots when plugged into the USB port of another computer in Windows 7 and in Linux computer (Ubuntu 18.04).

Here is my test code:

#include "mbed.h"

DigitalOut myled (LED1);
DigitalIn button (PA_7);

int main () {

   while (! button) {
     myled = 1; // LED is ON
     wait (1.0); // 1 seconde
     myled = 0; // LED is OFF
     wait (1.0); 
   }

  while (1) {
     myled = 1; // LED is ON
     wait (0.25); // 250 ms
     myled = 0; // LED is OFF
     wait (0.25); 
   }

}

A button is connected between PA_7 and + 5V, a restoring resistor (15kohm) between PA_7 and GND.

At startup (or restart) the LED flashes at 0.5 Hertz, after pressing the button connected to PA_7 the LED flashes at 2Hz.

The reaction is the same whether I compile with MBED or with MBED OS.
If you have an idea on the origin of the problem ?

Marc.

Hi
Try the latest STLink FW: https://www.st.com/en/development-tools/stsw-link007.html

Thank you very much for your answer,
I first tried to update the ST-LINK driver
After that, I had to restart the computer, the operation was not yet stable (I had the impression that things were continuing to implement this in Windows 10).
I then installed the ST-LINK firmware upgrade
After that, I restarted the computer again, the operation was still not stable (and I still had the impression that things continued to set it up).
I installed ST-LINK utility
Then I restart. It functioned. But I don’t think the ST-LINK utility had anything to do with it. I thought rather that it was the update of the driver ST-LINK or the update of the firmware.
But according to your answer it would rather be the firmware.
Marc.