Upate mbed-os library to latest in online simulator?

Currently mbed-os library that runs in the online simulator is an outdated fork of the main mbed-os repository.

contents of mbed-os.lib hosted in the simulator (https://github.com/ARMmbed/mbed-simulator) are:
https://github.com/janjongboom/mbed-os/#3b71b16e10c6e74f63b1c118cd4a10039f4362bd

and should point at least a mainstream version of mbed-os library, or ideally the latest version.

Currently the latest mbed-os library lacks TARGET_SIMULATOR option in the mbed-os/targets folder, hence any update of the mbed-os.lib file in the simulator will not let the compiler build the test code.

There is a pull request in the mbed-os GitHub repository, where the original mbed-simulator maintainer (janjongboom) tried to merge to a mainstream branch, but the request was rejectected, and no further actions was taken. Later the mbed-simulator project was abandoned and the maintainer left mbed team .

Github repository of the mbed-simulator lacks an Issue section, where we could rant about this to the current maintainers. Apparently there is no intention in the mbed team in solving this issue since ARM is promoting FastModels for simulation (which require a licence).

Is there anyone in the community solved this issue, or willing to team-up and create an updated TARGET_SIMULATOR for the latest mbed-os?

regards

1 Like