Word wrap stuck at 81 columns

This has been a minor annoyance since using mbed studio.
After shift-alt-F any lines that go past 81 columns wrap.
This can make some heavily indented code and multiple condition if statements hard to read.

In preferences, I’ve tried disabling word wrap. I’ve changed the columns to various numbers under user and workspace. None of it seems to make any difference. Am I missing something?