Blinky & error -230

I am trying to follow this page – https://docs.mbed.com/docs/mbed-os-handbook/en/5.1/getting_started/blinky_compiler/ – but I am getting an error -230, which tells me there is a syntax error in assembly.

Any idea what’s going wrong? All I did was click on Import into mBed IDE, and then Compile.

Hi,

What type of target are you using?
Also, can you ensure you are using the latest version of the online compiler - https://os.mbed.com/
You have to sign up if you do not have an account already.

Thanks for your response, Viji. I presume that the target is micro:bit (at least that’s what I see in the top-right). The url is os.mbed.com, so I further presume that I’m using the correct version.

I have the same issue on lpc11u24 board.

Nobody ever got back to me :frowning:

mprogers,

I’m really sorry for no-one getting back to you sooner.
It seems that the example is not handling the default build config correctly for BBC micro:bit.
Your screenshot shows Default next to “BBC micro:bit”. You can change this to Boot or Fota to explicitly specify build config.
However, it is not much of a help, since example-blinky does not currently fit into the memory of micro:bit.

Instead, if you could please take a look at specific blinky demo, which compiles OK also with Default build configuration for BBC micro:bit:
https://os.mbed.com/teams/BBC/code/microbit_blinky/

Thanks,
Jyri

Hi Renan,

Referring to this information:
https://os.mbed.com/questions/77323/I-cant-compile-Mbed-RTOS-on-LPC11u24/
Mbed OS 5 is too large to fit into lpc11u24 uC memories.

Please use this blinky example to get started:
https://os.mbed.com/teams/mbed/code/mbed_blinky/?platform=mbed-LPC11U24

I recon it might not be very clearly visible on the platform/board page which versions of OS are supported. You can find this information from the right hand sidebar with a note to Mbed Enabled and Mbed OS 2 or Mbed OS 5 for example.

Thanks,
Jyri

1 Like

Hi sirjyge,
Thanks for your reply, i discover that is the cause of the error, using the mbed-cli yesterday. You confirmed my doubt, thank you!!!