Cannot view serial output in debugger

Simple OS6 program using printf. Works fine if I compile and use the drag and drop method from downloads and outputs to tera term.
When I debug in Keil Studio I can single step, … but nothing shows up on the KS serial monitor. I’ve tried various baud rates.

The interface has the >_ selector greyed out, and when hovered says “cannot view serial output on connected device”

device is NUCLEO 476RG

Hello @tjj,

Serial Monitor is enabled for all devices only in Mbed Studio.
In Keil Studio Cloud we enabled it only for devices that use DAPLink firmware. It doesn’t work yet with ST devices that use STLink. We are working on enabling it.

Kind regards,
Aleksandra - Studio team

Thanks Aleksandra,

To follow up in case others want to use the debugger with STM

I tried running the Keil Studio debugger with Tera Term open and connected, and the Serial I/O was redirected to Tera Term.
This worked with printf and scanf.

Is this likely to change?

Hi Nicholas,

Yes it is. We are currently implementing serial monitor support for ST devices in Keil Studio Cloud. I don’t know yet the exact release date but it is not that far from now.

Arek - Studio team