Arm Mbed and Pelion Device Management support forum

Cant select custom targets after autoupdate to 0.9.0.12

Mbed Studio just auto-updated to 0.9.0.12 and now projects using custom targets, that worked previously are no longer able to select that target

Running OSX 10.13.6

Tried completely removing the application and all support files, doing a fresh install - no difference

Reverting to a old version (0.7.0) and the custom target is selectable

Anyone else come across this or have any ideas?

Cheers

2 Likes

Thanks for reporting this, we’ll investigate and release a patch if there’s a regression here.

Thought I’d chip in and mention that that’s also an issue for me and my colleagues. On Windows 10 Pro v1909.

Mbed Studio v0.8.1 was the last release where we could use custom targets.

Cheers,
Adam

1 Like

We’re now building a patch release to fix the custom target support, which will appear as 0.9.1. If all goes well we’ll make this available today (Friday 13th always good for quick patch releases…!).

2 Likes

Where I can get patch release 0.9.1?
In the official page, I can see only 0.9.0.
Thanks your help in advance!

Hi @andy_h_nz, @amitchone, @kenji_tokyo,

Mbed Studio 0.9.1 has just been released. As usual, you can either:

Selecting custom targets should be working again in this release. We apologize for the inconvenience and please let us know if there is any functionality that doesn’t work for you.

Thanks,
Arek - Mbed Studio team

Thanks for all the effort guys!

I confirmed that I can compile the category of “MCUs and Custom targets”.
Thanks your support.

1 Like

I can compile with custom board too after update to 0.9.1, but when I close mbed studio and reopen it later I have to re-select my custom board in project manager. Previous choice is lost and project manager reverts to “regular” board …

A little problem seems persist in custom boards support …

Thanks for reporting that, we’ll investigate.