Arm Mbed OS support forum

Combination of fedora and Mbed CLI induces filesystem errors

Hi,

I just want to report some occurence that happened to me lately.

I had the mbed CLI installed on a fedora 31 linux. After flashing my device (nucleo-f446re) with a slightly modified version of the blinky example, my filesystem (ext4) went into read-only mode.
After rebooting, I was greeted with a message, that my root account is locked and I could’nt boot the system fully. I tried solving this issue over several hours. In the end I gave up, read out my important files via chroot and a live os and reinstalled a clean fedora. Since then I have not faced this issue again.

Now the same thing happened to a friend of mine on a freshly installed fedora 33 linux. He tried to flash the nucleo which failed. The nucleo could not be detected w/ “mbed detect”. After a reboot the system went into the same error screen as mine (image in the appendix).
He found a Fail.txt on the nucleo which said something like “failed to hard reset the MCU”. The exact wording could unfortunately not be remembered.

He used a btrfs filesystem, I was using ext4 on LVM. I don’t think the issue was here.

Do you have any idea why this might be?
Maybe the OS is mounting the device with the wrong UUID and mbed-cli tries to access a wrong device? This does not explain why flashing has been working before the issue occured.
I just don’t want the system to be crashing anymore, because the reinstall did cost me the whole weekend.

Best regards!

2020-12-02T18_44_57.247Z|690x388