Little File system fail on Mbed studio 1.4.4

I have tried using LitteFileSyetem on BlackPill STM32F411CE very recently
I tried using both MbedStudio as well as Keil online compiler.

Error is : lfs error:494 : Corrupted dir pair at 0 1
lfs error:2222 : Invalid superblock at 0 1
Used Heapblock device. But error happens with SD cards as well.
Can someone look into this in detail, please?
Kind Regards
Dingle Jose


I think there are missing additional information for potential people who will want to solve it.

  • more important than Mbed Studio version will be probably Mbed OS version. Or did you found another tool (Cli or Online compiler) where this issue does not occur on same MbedOS version?
  • does it also appear with the oficial example of LFS? - LittleFileSystem - API references and tutorials | Mbed OS 6 Documentation
  • what method return this error or how can be achieved this state?

Maybe related - LittleFS: Meet bad block on master · Issue #11924 · ARMmbed/mbed-os (

BR, Jan