Arm Mbed and Pelion Device Management support forum

Disabling LSE on a custom STM32H743ZI board

I have a custom board with an STM32H743ZI but no LSE crystal. I’ve set the “lse_available” flag to 0. However I continue to get a “HAL_RCC_OscConfig” error as the mbed libraries load during boot.

Additionally I have a variant of the same custom board with an STM32F767ZI instead. When compiling for this chip, setting the “lse_available” flag is sufficient to get my code running.

I also have Nucleo dev kits for both the STM32F767ZI and STM32H743ZI chips. My F7 build with LSE=0 runs fine on the F7 Nucleo. However, my H7 build with LSE=0 does not run on the H7 Nucleo. Removing the LSE flag allows me to build for the H7 Nucleo, but obviously does not work for my custom board.

Are there additional configuration or hardware changes required for the H7 vs the F7?

Online, Studio, CLI ?
What does your mbed_app.json look like?

CLI

I have a custom_targets.json file that looks like:

{
    "CUSTOM_TARGET": {
        "inherits": ["NUCLEO_H743ZI2"],
        "overrides": {
            "lse_available": "0"
        }
    }
}

And an mbed_app.json that has:

"config": {
        "default_target": {
            "value": "xxx"
        },
}

Where xxx is either: “CUSTOM_TARGET” or “NUCLEO_H743ZI2”

I don’t do CLI, but I have tried this with Online and Studio.
Both H743 and F767 compile and run with that

“lse_available”: “0”

But not possible for me to test as almost all ST boards are now fitted with the 32kHz Xtal.
I did notice there was no change in the 32kHz xtal waveform on both boards, they were constantly very low level at all times.