Arm Mbed OS support forum

STM32F767ZI: HAL_RCC_OscConfig ERROR

When flashing simple code (blinky for example) on our custom board with a STM32F767Zi MCU, we keep getting the following fatal runtime error: “HAL_RCC_OscConfig ERROR”. When we compile and flash using the Mbed online compiler with Mbed 2 everything seems to work fine. Does anybody have any ideas as to why this error could occur only when using newer Mbed versions? We have tried target overrides that use either the HSE or HSI, with no effect.

Hi

“HAL_RCC_OscConfig ERROR” comes from lp_ticker init…
Do you have a LSE in your custom board ?

Hello Jerome,

I have the same problemen with a stm32l072.
I have a have a external 32.768khz LSE on. My custom board. Using mbed is 6.1.

Do you have some tips how I can fix this?

Thanks!

Hello,

The same error for our custom board using the STM32WB55CG uC with new mbed-os-6.2.0.

There is no error on the previous mbed-os-5.x.

As our custom board hasn’t no LSE xtal but only HSE 32Mhz, this extra config is added to .json file on the mbed-os-6.2.0

  • “lse_available” : 0
  • “RCC_RTCCLKSOURCE_NO_CLK=0” (without this define, the compilation fails)

Thanks.

P.S: there is no error if running the board in debuging mode (openocd) (step by step during SetSysClock())

My problem was the LSE. I desolderd it and replaced, now the problem solved.