Half dead MBED _strange behavier

I have (had :sweat_smile:) fully working MBED 1768 module using with few LEDs and network.When I tried to complie the same program in to Seeed Studio Arch PRO 1768 a message came up on offline compiler(I think some thing about default settings on Arch Pro…Sorry I didnt read properly :flushed:), pressed ok and it all seems good . I had to do firmware update on Arch Pro before get it working .I didnt check LED output but web server seems work fine.
Now when I go back to my original setup with MBED 1768 some of the LED outputs aren’t working. Even I tried online compiler with simple blinky. Its only working on LED1-4, P7,P13 only. I didn’t change anything on hardware.
Did I mess up the MBED firmware or any setting on offline compiler?
here is my test blinky

Best Regards

#include "mbed.h"

DigitalOut myled1(LED1);
DigitalOut myled2(LED2);
DigitalOut myled3(LED3);
DigitalOut myled4(LED4);
DigitalOut myled5(p5);
DigitalOut myled6(p6);
DigitalOut myled7(p7);
DigitalOut myled8(p5);
DigitalOut myled9(p6);
DigitalOut myled10(p10);
DigitalOut myled11(p11);
DigitalOut myled12(p12);
DigitalOut myled13(p13);
DigitalOut myled14(p14);
DigitalOut myled15(p15);
DigitalOut myled16(p16);
DigitalOut myled17(p17);
DigitalOut myled18(p18);
DigitalOut myled19(p19);
DigitalOut myled20(p20);

int main() {
    while(1) {
        myled1 = 1;
        myled2 = 1;
        myled3 = 1;
        myled4 = 1;
        myled5 = 1;
        myled6 = 1;
        myled7 = 1;
        myled8 = 1;
        myled9 = 1;
        myled10 = 1;
        myled11 = 1;
        myled12 = 1;
        myled13 = 1;
        myled14 = 1;
        myled15 = 1;
        myled16 = 1;
        myled17 = 1;
        myled18 = 1;
        myled19 = 1;
        myled20 = 1;
        myled1 = 0;
        myled2 = 0;
        myled3 = 0;
        myled4 = 0;
        myled5 = 0;
        myled6 = 0;
        myled7 = 0;
        myled8 = 0;
        myled9 = 0;
        myled10 = 0;
        myled11 = 0;
        myled12 = 0;
        myled13 = 0;
        myled14 = 0;
        myled15 = 0;
        myled16 = 0;
        myled17 = 0;
        myled18 = 0;
        myled19 = 0;
        myled20 = 0;

Hello Dan,

Have you tried a Mbed LPC1768 firmware update ?

Best regards,


Hi Zoltan,
I tried below with downloading latest firmware, still no luck.



Hello Dan,

Try it again and read the message carefully. Press [Cancel] and let us know the message showed by the offline compiler.

Hi Zoltan

I pressed yes;
And its vey simple circuit as well

I tried blinky on offline compiler and when I press Run Programme it crashes. But the program is download in to MBED. Once I press reset its running.

#include "mbed.h"
#include "platform/mbed_thread.h"

// Blinking rate in milliseconds
#define BLINKING_RATE_MS             500

int main()
    // Initialise the digital pin LED1 as an output
    DigitalOut led(LED2);

    while (true) {
        led = !led;
   //    int n=led.is_connected();
     // printf("N=%d\n",n);

Hello Dan,

I have found an old thread with this advice from Chris Styles:

  • Press and hold reset button down.

  • Plug the mbed in to your PC (keeping the button held down).

  • When the removable drive appears reformat it (still with the button held down).

  • Unplug the mbed.

  • Plug it back normally (without the reset button being held).

It is important to keep the reset button held down so that the target is in reset and is unable to interfere with the file system.

Best regards,


Hi Zoltan,
Tried few times N it did work :grinning: