Arm Mbed OS support forum

MBED OS is absolute trash

I have been using mbed 2 for ages
Trying to start a project on mbed OS 5 or 6 and it has been days and I still cannot even get a blinky example to compile
Tried mbed Studio and online compiler, it just always comes up with errors
Finally got the mbed blinky to work and the delay on the LED is nowhere near 500ms, it’s more like 5 seconds
Using LPC1768
Is anyone actually using this?

Hello,

please be so kind and provide more information about your issue, especially some steps for reproducing, for sure.
Place here a link of the example or the code, what you exactly tried.

I not have this target but LPC1768 is very popular I think. So someone who verifies it will definitely be found.

BR, Jan

I think you need to update your firmware. Try installing the latest one. You can find it here.

I just finished a project a few months ago using MBed 5.0 and the LPC1768. I had problems with ram usage and the debugger never worked(Segger J-Link Base). If you have ram usage problems I would recommend using the GCC compiler instead of the standard compiler as it seems to be better at putting objects into rom instead of ram.

Good Luck.

The LPC1768 timing issue is due to the firmware, update it and it works fine.
Although this target works well, its a little bit dated now and limited compared with other devices. Can’t use TLS , low power is a no go and speed is average. A great platform to get started though.

OS5 has been a nightmare until more recently, far too much depreciated code going on and documentation was appalling.
However its turned around now and I’m using OS6 on Mbed Studio offline with no problems and the documentation is starting to make sense.
After the first initial compile, subsequent re compiles are very fast, far quicker than online.
I’m using it most of the time now.

Studio online compiler looks and feels exactly the same as the off line version and will be a good replacement for the current online compiler.

I can’t see OS6 being usable on low resource targets (Flash below 64k and sub 80Mhz) unless you want to simply flash an LED.
However there is no reason for Mbed not to enable the last version of OS2 Mbed-Dev library set (officially unsupported) to be available on Studio for the ‘smaller’ targets.

1 Like