Arm Mbed OS support forum

How do I tell which version of Mbed I'm using?

I’d thought that Mbed Studio was built on Mbed v5.
Last night I was trying to change the serial pins for the serial monitor on an Nuvoton M453.
I’d done this before on an STM32 under v2 and v5 using the Serial API, which was pretty straight forward. The same code wouldn’t compile on Mbed Studio 1.41.

I tried using BufferedSerial, which would compile if I only called the constructor, but when I tried setting it up further using this code as an example I’d get errors. mbed-os-snippet-BufferedSerial_printf/main.cpp at v6.10 · ARMmbed/mbed-os-snippet-BufferedSerial_printf · GitHub

I did manage to get it working another way, but not knowing what version I’m on means I don’t know which documentation is relevant.

Hello,

  • You can see the version in the Libraries card of Mbed Studio, like on first picture of this page from documentation.
  • MbedOS library also contains mbed_version.h file, you can find it on path - mbed-os/platform/ or mbed-os/platform/internal/. From this file also come those macros what are used in the example what you linked above. So, you can right click on the macro and select “Go to Definition”.

BR, Jan

2 Likes

Thank you so much. I saw the page you linked to last night, but misunderstood the instructions and didn’t use the view menu.

I’ve mostly used the online compiler and I’m still getting acquainted.