Arm Mbed OS support forum

Impossible to open my application

Hello,
I use Mbed studio for days to work on an application. I just migrated Mbed OS to 6 beta 1 and I worked perfectly with it. After my pause I tried to reopen Mbed Studio and impossible to make my application active to work on it, not listed in applications too. What can I do please ?

Hi there,

this usually occurs when the MbedOs in the project folder is not valid or do not exist.
You can try these steps:

  • Create a new empty project in the MbedStudio but it is not necessary to set it to active
  • Close the MbedStudio
  • Open your folder with MbedStudio projects
  • Copy/replace mbed-os folder and mbed-os.lib file from the new empty project folder to your project folder
  • Run the MbedStudio

BR, Jan

Hello,
Thank you for your help.
Is that possible that my replacement of mbed-os folder with 6 beta 1 version cause the problem. I was able to work before closing mbed studio. Can I bluff it make it imagine that is a os 5 ?

Hi,

It sounds like you replaced mbed-os manually? You can just use the library panel to change from OS 5 to 6 since they are in the same repo.

If you did swap the library folder manually, you will also need to update the .lib file to point at the right commit (you can make it visible in the file tree by opening File > Preferences > Files > exclude and then change .lib to false:

1 Like

Ok. Thank you Mr Alderson