Arm Mbed OS support forum

Interactive mode (ctrl navigation) does not work

The interactive mode stopped working, I tried to re-install mbed studio but it still doesn’t work.

Is there any fix for that?

1 Like

Hi Rafaella,

Thank you for reporting this issue. By interactive mode do you mean a C/C++ intellisense (navigation, auto-completion, etc…)? I have few follow-up questions that will help us understand the problem.

  1. Has it stopped working for a single program in your workspace or it doesn’t work at all?
  2. What platform are you on?
  3. Would you mind sending logs? That will help us investigate the problem. You can use a built in report feature. Menu->Help->Report an Issue

It is also important to point out that at the moment Mbed Studio supports intellisense only for an active program. We are looking at enabling intellisense for all programs in the workspace.

Arek - Mbed Studio team

Hello, it seems that it doesn’t work because I am using a custom Target. If i change the target it works.

Is the intellisense not working with custom targets?

1 Like

Hi, any more info on this?
Indeed, even with Mbed Studio 1.0 the code ‘navigation’ does not work for custom targets.

Same issue here: IntelliSense not working when i switch to a custom target.
(It works fine with official targets)

It still doesn’t work for custom targets