Arm Mbed and Pelion Device Management support forum

Lpc55s69-evk mbed download error

We have a problem downloading any *.hex onto the lpc55s69-evk USB mass storage device. The debug device has been updated with the latest lpc4322_bl_crc.bin and lpc4322_lpc55s69xpresso_if_crc.bin from We have tried downloading from a Windows and from Linux computers. We have tried various *.hex files, prebuilt and built using online compiler and built by local mbed environment. We have tried on two individual lpc55s69-evk boards - no success on both.

The behavior is: As soon as the *.hex is copied to the “LPC55S69” USB device the software running on the Cortex 33 stops (e.g. a preprogrammed blinky stops) and nothing else happens. I’d have expected that the
Link2 boot LED is flashing. Mostly it stays dark, sometimes it just lights up. The copy process to the USB device does not get finished. If one waits long enough or presses the RESET button the FAIL.txt on the USB mass storage device contains: “Error: The interface firmware failedto reset/halt the target MCU”

The only thing that works is building and downloading using the NXP MCUxpresso IDE. This means the hardware is not the issue.

It pretty much looks like the lpc4322 on-board debugger cannot program the *.hex on the Cortex M33 flash. I suspect that the lpc4322_lpc55s69xpresso_if_crc.bin firmware does not do its job properly. Does anybody have a similar experience or knows how to fix this?

Thanks in advance

1 Like