Arm Mbed OS support forum

K64F "The interface firmware FAILED to reset/halt the target MCU"

I am getting a “FAIL.TXT” file when I try to flash my brand new K64F board even with the blinky program. I have followed the steps in DAPLink bootloader update | Mbed to update the DAPLINK bootloader and used exactly the same steps to update the interface firmware on all my other K64F boards, all of which I am able to flash no problem. I have checked that all the jumpers are in the correct positions on the board and I tried using an erase.act file to make sure that no program is preventing the flashing. Any advice on this would be appreciated.

FAIL.TXT
error: The interface firmware FAILED to reset/halt the target MCU
type: target

DETAILS.TXT
DAPLink Firmware - see Free open source IoT OS and development tools from Arm | Mbed
Unique ID: 0240000053274e4500338004f5a20018bd81000097969900
HIC ID: 97969900
Auto Reset: 0
Automation allowed: 0
Overflow detection: 0
Daplink Mode: Interface
Interface Version: 0253
Bootloader Version: 0244
Git SHA: 64359f5c786363065a41ec15c348e3d53568da03
Local Mods: 0
USB Interfaces: MSD, CDC, HID, WebUSB
Bootloader CRC: 0xca4adf2f
Interface CRC: 0x08858a9a
Remount count: 3
URL: Development boards | Mbed

Hello,

It seems like no one know exact answer because I saw many unanswered questions related to this issue here.
Frequent recommendation is update, what you already tried how you wrote above.

If you will found a solution, please let us know.

BR, Jan

You can change the MCU(K64F).Generally the MCU is broken, just change it.

UPDATE:

It seems the solution is to debug the K64F using an LPC-LINK (I tried the LPC-LINK 2), with the goal of using it with the JLINK application to erase the memory of the K64F. As per this community post.

However my LPC-LINK 2 would not work out of the box with my Win 10 PC. I tried the following steps that I found online for getting my LPC-LINK to enumerate:

Firstly I installed LPCScript along with the shipped drivers and tried to update the interface firmware on the LPC-LINK 2 using ‘program_JLINK’ from ‘LPCScript’, but this gave me error message ‘nothing to boot’. The board is not recognised by Win 10 when connected via the provided USB, even with the jumpers removed. I have tried connection on several Win 10 PC’s.

I then tried to manually boot my LPC-LINK 2 by installing LPCXpresso along with the shipped drivers. I connected my LPC-LINK 2 and ran ‘boot_link2’ from <install_dir>\lpcxpresso\bin but nothing happened. I also tried running ‘bootLPCXpresso.cmd’ from <install_dir>\lpcxpresso\bin\scripts. I was still unable to boot my LPC-LINK 2 from Win 10.

After weeks of troubleshooting this with the LPC team support, they suggested that I return the LPC-LINK under warranty.

Hopefully this is helpful to someone in the future.